Outbound Link Summary:
8 years ago
p3k dots

How to downgrade Git to version 1.8 on Ubuntu 14.04.

SparkleShare, the very excellent “Open Source collaboration and sharing tool” currently is not working with Git 1.9, the default version installed with Ubuntu 14.04.

So I did the following to downgrade Git to version 1.8 and make SparkleShare working again:

$ sudo aptitude remove git

The following packages will be REMOVED:
  git
0 packages upgraded, 0 newly installed, 1 to remove and 29 not upgraded.
Need to get 0 B of archives. After unpacking 20,2 MB will be freed.
The following packages have unmet dependencies:
 smartgithg : Depends: git but it is not going to be installed.
 git-gui : Depends: git (> 1:1.9.1) but it is not going to be installed.
           Depends: git (< 1:1.9.1-.) but it is not going to be installed.
 gitk : Depends: git (> 1:1.9.1) but it is not going to be installed.
        Depends: git (< 1:1.9.1-.) but it is not going to be installed.
 git-core : Depends: git (> 1:1.7.0.2) but it is not going to be installed.
 sparkleshare : Depends: git (>= 1:1.7.1) but it is not going to be installed.
The following actions will resolve these dependencies:

     Remove the following packages:
1)     git-core
2)     git-gui
3)     gitk
4)     smartgithg
5)     sparkleshare
6)     tig

     Leave the following dependencies unresolved:
7)     git-gui recommends gitk

Okay, that sounds fair enough as I requested to remove Git but nevertheless I would like to keep SparkleShare. As this is (hopefully) only the first of a bunch of solutions offered by Ubuntu I am cancelling this ticket:

Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     git [1:1.9.1-1 (now, trusty)]

Ahem. If I intended to keep Git at the current version I probably would not have instructed to remove it in the first place, would I? Not happening.

Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

     Downgrade the following packages:
1)     git [1:1.9.1-1 (now, trusty) -> 1:1.8.3.2-1 (saucy)]
2)     git-gui [1:1.9.1-1 (now, trusty) -> 1:1.8.3.2-1 (saucy)]
3)     git-man [1:1.9.1-1 (now, trusty) -> 1:1.8.3.2-1 (saucy)]
4)     gitk [1:1.9.1-1 (now, trusty) -> 1:1.8.3.2-1 (saucy)]

Hey, looking good! This is exactly the downgrade I want, so here goes a capital Y as in “let’s do thYs!”:

Accept this solution? [Y/n/q/?] Y
The following packages will be DOWNGRADED:
  git git-gui git-man gitk
0 packages upgraded, 0 newly installed, 4 downgraded, 0 to remove and 29 not upgraded.
Need to get 9.126 kB of archives. After unpacking 2.144 kB will be freed.
Do you want to continue? [Y/n/?] Y
Get: 1 http://archive.ubuntu.com/ubuntu/ saucy/universe git-gui all 1:1.8.3.2-1 [286 kB]
Get: 2 http://archive.ubuntu.com/ubuntu/ saucy/main gitk all 1:1.8.3.2-1 [135 kB]
…
Setting up git-gui (1:1.8.3.2-1) ...
Setting up gitk (1:1.8.3.2-1) ...

Oh, and as I am going to stay with this Git version until SparkleShare tells me to do otherwise, I am putting the “hold” mark on its forehead:

$ sudo apt-mark hold git
git set on hold.